[Payments]
Incident Report for VPSServer.com
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 17:28 UTC
Monitoring
Our payment provider has implemented a fix, our payments system should work again.
Posted Sep 16, 2020 - 17:26 UTC
Identified
Our payment provider is experiencing infrastructure issues. They are looking into it.
If you do see payment errors, please try again at a later time.

Sorry for the inconvenience.
Posted Sep 16, 2020 - 17:16 UTC
This incident affected: Customer Portal.