Singapore maintenence
Incident Report for VPSServer.com
Resolved
Upgrade has been completed.
Posted 8 months ago. Sep 03, 2018 - 10:25 UTC
Monitoring
We are upgrading hardware in Singapore. We do apologise for the inconvenience.
Posted 8 months ago. Sep 03, 2018 - 05:58 UTC
This incident affected: Singapore - Asia.